Poster une réponse 
 
Note de cette discussion :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Mon VHS-4 a rendu l'âme....
23-11-2019, 11:51:19
Message : #11
RE: Mon VHS-4 a rendu l'âme....
(23-11-2019 10:52:37)Cram28 a écrit :  Bonjour micnad,

Il existe pas une option "installation personnalisée": tu sélectionnes tes partitions existantes et tu coches pas "formater" ?
Pffff je sais pas en fait Huh

Sinon, tu mets la main sur GParted en live usb, tu bootes dessus et tu fais le ménage par suppression.

@+, bon courage.
Bonjour.
J'ai vu sur le net que gparted est dans l'incapacité de supprimer un raid et qu'une info reste persistante sur le disque (superblock).
Je vais quand même essayer.
J'ai également trouver ce tuto : https://debian-facile.org/doc:install:su...-logiciel.
Je raconterai ce que cela a donné.
Merci

VHS-4 home server Extrême I
Amd Athlon ™ II X2 235e
Processeur 2700 MHz
2048 Mo mémoire
4 X 4To Raid5 WD40EFRX-68NTONO
Clé usb à l'arrière du vhs-4 pour HDD > 2to
Version micro logiciel : 6.1.4

En informatique, j'ai tout à apprendre.
Je suis septuagénaire.
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
23-11-2019, 16:28:20 (Ce message a été modifié le : 23-11-2019 16:29:13 par Epy.)
Message : #12
RE: Mon VHS-4 a rendu l'âme....
Je confirme c'est très chiant d'arriver à réutiliser ailleurs (LVM dans mon cas) un disque qui a servi dans un RAID logiciel. C'est une protection en quelque sorte mais elle est trop sévère

Désolé je ne me souviens plus des commandes utilisées, j'espère que ton lien fonctionnera

VHS4 Xtreme II - AMD Athlon II X2 240e
OS: v6.1.3 / RAM: 6 Go / Stockage: 1x 2To

[Image: wiki:favicon-32.png]Wiki madovi.xyz
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
23-11-2019, 17:59:50 (Ce message a été modifié le : 23-11-2019 19:10:26 par micnad.)
Message : #13
RE: Mon VHS-4 a rendu l'âme....
Salut.
En suivant les instructions trouvées dans le lien que je cite dans mon post ci-dessus, j'ai réussi à remettre les 4 hdd du vhs en situation d'utilisable pour une nouvelle installation.
Hélas OMV DOIT être installé pour ensuite configurer les disques en raid. Et comme je souhaite que le système soit sur les HDD comme .le faisait ve-hotech, je persiste à essayer de reproduire cette technique...
Du coup je suis occupé à faire une installation de debian duster qui permet de faire la création des 2 raids et ensuite je tenterai une superposition d'OMV sur cette debian en suivant ces instructions

Bonsoir
L'installation de debian est terminée.
Mais si je veux me connecter j'arrive sur cette page et je ne comprends rien...
apparemment un fichier à modifier ???
HELP. merci
Code :
Debian LogoApache2 Debian Default Page
It works!
This is the default welcome page used to test the correct operation of the Apache2 server after installation on Debian systems. If you can read this page, it means that the Apache HTTP server installed at this site is working properly. You should replace this file (located at /var/www/html/index.html) before continuing to operate your HTTP server.

If you are a normal user of this web site and don't know what this page is about, this probably means that the site is currently unavailable due to maintenance. If the problem persists, please contact the site's administrator.

Configuration Overview
Debian's Apache2 default configuration is different from the upstream default configuration, and split into several files optimized for interaction with Debian tools. The configuration system is fully documented in /usr/share/doc/apache2/README.Debian.gz. Refer to this for the full documentation. Documentation for the web server itself can be found by accessing the manual if the apache2-doc package was installed on this server.

The configuration layout for an Apache2 web server installation on Debian systems is as follows:

/etc/apache2/
|-- apache2.conf
|       `--  ports.conf
|-- mods-enabled
|       |-- *.load
|       `-- *.conf
|-- conf-enabled
|       `-- *.conf
|-- sites-enabled
|       `-- *.conf
          
apache2.conf is the main configuration file. It puts the pieces together by including all remaining configuration files when starting up the web server.
ports.conf is always included from the main configuration file. It is used to determine the listening ports for incoming connections, and this file can be customized anytime.
Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/ directories contain particular configuration snippets which manage modules, global configuration fragments, or virtual host configurations, respectively.
They are activated by symlinking available configuration files from their respective *-available/ counterparts. These should be managed by using our helpers a2enmod, a2dismod, a2ensite, a2dissite, and a2enconf, a2disconf . See their respective man pages for detailed information.
The binary is called apache2. Due to the use of environment variables, in the default configuration, apache2 needs to be started/stopped with /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not work with the default configuration.
Document Roots
By default, Debian does not allow access through the web browser to any file apart of those located in /var/www, public_html directories (when enabled) and /usr/share (for web applications). If your site is using a web document root located elsewhere (such as in /srv) you may need to whitelist your document root directory in /etc/apache2/apache2.conf.

The default Debian document root is /var/www/html. You can make your own virtual hosts under /var/www. This is different to previous releases which provides better security out of the box.

Reporting Problems
Please use the reportbug tool to report bugs in the Apache2 package with Debian. However, check existing bug reports before reporting a new bug.

Please report bugs specific to modules (such as PHP and others) to respective packages, not to the web server itself.

VHS-4 home server Extrême I
Amd Athlon ™ II X2 235e
Processeur 2700 MHz
2048 Mo mémoire
4 X 4To Raid5 WD40EFRX-68NTONO
Clé usb à l'arrière du vhs-4 pour HDD > 2to
Version micro logiciel : 6.1.4

En informatique, j'ai tout à apprendre.
Je suis septuagénaire.
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
23-11-2019, 21:10:43
Message : #14
RE: Mon VHS-4 a rendu l'âme....
Hello,

Epy a écrit :Désolé je ne me souviens plus des commandes utilisées
Retrouvé ! Tu avais dit:
Citation :Au final la manip qui a fonctionné la deuxième fois quand j'ai appelé au secours sur Maston, c'est d'installer l'utilitaire mdadm et la commande
Code :
#> mdadm --zero-superblock /dev/sdX
C'était ici

Pour ce qui est de ton installation micnad, tu es bien en RAID sur le système ?
Que retourne la commande (depuis que j'ai mis la main dessus, je l'utilise à toutes les sauces Wink) :
Code :
$ lsblk -o name,model,type,size,fstype,state,mountpoint


Tu as installé Debian Buster et tu as dû cocher "Serveur Apache" dans les options.
Cette page te confirme juste que ton serveur web Apache fonctionne, mais que rien n'y est configuré: normal.

Pour moi, à ce stade tout va bien si tu es bien en RAID sur le système.
Il te "suffit" maintenant d'installer le paquet OMV pour pouvoir accéder à son interface. J'ai trouvé quelques liens - en anglais Sad:
- https://openmediavault.readthedocs.io/en...ebian.html
- https://forum.openmediavault.org/index.p...10-Buster/

Peut-être faire une recherche plus poussée ?

Bonne manip.
@+

[Image: logo-forum.png]
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
24-11-2019, 02:58:02
Message : #15
RE: Mon VHS-4 a rendu l'âme....
Heureusement qu'on a notre encyclopédie vivante sur le forum ! Merci Cram, again Smile

Et tout pareil que Cram pour la page "It Works", il manque "l'appli Web" OMV en gros

VHS4 Xtreme II - AMD Athlon II X2 240e
OS: v6.1.3 / RAM: 6 Go / Stockage: 1x 2To

[Image: wiki:favicon-32.png]Wiki madovi.xyz
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
24-11-2019, 11:58:14
Message : #16
RE: Mon VHS-4 a rendu l'âme....
Big Grin
Et pourtant, j'ai une mémoire de poisson rouge.

En fait, pas pour tout apparemment, j'ai la mémoire sélective Tongue

[Image: logo-forum.png]
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
24-11-2019, 14:56:28 (Ce message a été modifié le : 24-11-2019 16:13:31 par micnad.)
Message : #17
RE: Mon VHS-4 a rendu l'âme....
Bonjour et merci.
Merci pour les infos sur OMV
J'ai fait une installation "server" de DEBIAN. Donc sans interface graphique.
Quand le serveur démarre et qu'il arrive à la saisie du login et du MdP, il les accepte.
Mais quand je lance putty sur mon pc, avec les mêmes identifiants, il refuse la connexion.

Pourtant j'ai bien coché le ssh durant l'installation.
Une idée
@Cram28 : qu'il est beau le résultat de ta ligne de commande, mais impossible de recopier le résultat à partir du serveur. Il faut absolument régler ce problème avec Putty.
Merci

VHS-4 home server Extrême I
Amd Athlon ™ II X2 235e
Processeur 2700 MHz
2048 Mo mémoire
4 X 4To Raid5 WD40EFRX-68NTONO
Clé usb à l'arrière du vhs-4 pour HDD > 2to
Version micro logiciel : 6.1.4

En informatique, j'ai tout à apprendre.
Je suis septuagénaire.
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
24-11-2019, 15:09:32 (Ce message a été modifié le : 24-11-2019 15:23:06 par Cram28.)
Message : #18
RE: Mon VHS-4 a rendu l'âme....
Hello micnad,

Bizarre...
Que donne :
Code :
$ dpkg -l | grep openssh

PuTTY te donne la raison du refus ?

(j'aimerais bien voir le beau résultat Tongue)


Et depuis ton poste où il y a PuTTY, le ping fonctionne (sur la console commande) ?
Et est-que ssh écoute, s'il est installé ? Par exemple:
Code :
$ ss -tlp | grep ssh
LISTEN    0         128                0.0.0.0:ssh               0.0.0.0:*      
LISTEN    0         128                   [::]:ssh                  [::]:*
...
?

[Image: logo-forum.png]
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
24-11-2019, 15:50:56 (Ce message a été modifié le : 24-11-2019 16:21:35 par micnad.)
Message : #19
RE: Mon VHS-4 a rendu l'âme....
Salut
Avec putty, je ne peux pas me connecter avec le compte root qui est défini pendant l'installation de debian.
Par contre, avec ce même putty je peux me connecter avec le compte user créé pendant l'installation.
Le mot de passe root est exact puisque je me connecte avec celui-ci sur le vhs.
Code :
micnad@VHS-4:~$ lsblk -o name,model,type,size,fstype,state,mountpoint
NAME       MODEL                TYPE   SIZE FSTYPE            STATE   MOUNTPOINT
sda        WDC_WD40EFRX-68WT0N0 disk   3,7T                   running
├─sda1                          part   953M vfat                      /boot/efi
├─sda2                          part  18,6G linux_raid_member
│ └─md0                         raid1 18,6G ext4                      /boot
├─sda3                          part   4,7G swap                      [SWAP]
└─sda4                          part   3,6T linux_raid_member
  └─md1                         raid5 10,9T LVM2_member
    └─vHD-vPart1
                                lvm   10,9T ext4              running /
sdb        WDC_WD40EFRX-68WT0N0 disk   3,7T                   running
├─sdb1                          part   953M vfat
├─sdb2                          part  18,6G linux_raid_member
│ └─md0                         raid1 18,6G ext4                      /boot
├─sdb3                          part   4,7G swap                      [SWAP]
└─sdb4                          part   3,6T linux_raid_member
  └─md1                         raid5 10,9T LVM2_member
    └─vHD-vPart1
                                lvm   10,9T ext4              running /
sdc        WDC_WD40EFRX-68WT0N0 disk   3,7T                   running
├─sdc1                          part   953M vfat
├─sdc2                          part  18,6G linux_raid_member
│ └─md0                         raid1 18,6G ext4                      /boot
├─sdc3                          part   4,7G swap                      [SWAP]
└─sdc4                          part   3,6T linux_raid_member
  └─md1                         raid5 10,9T LVM2_member
    └─vHD-vPart1
                                lvm   10,9T ext4              running /
sdd        WDC_WD40EFRX-68WT0N0 disk   3,7T                   running
├─sdd1                          part   953M vfat
├─sdd2                          part  18,6G
├─sdd3                          part   4,7G swap                      [SWAP]
└─sdd4                          part   3,6T linux_raid_member
  └─md1                         raid5 10,9T LVM2_member
    └─vHD-vPart1
                                lvm   10,9T ext4              running /

micnad@VHS-4:~$ dpkg -l | grep openssh

Code :
micnad@VHS-4:~$ dpkg -l | grep openssh
ii  openssh-client                 1:7.9p1-10+deb10u1           amd64        secure shell (SSH) client, for secure access to remote machines
ii  openssh-server                 1:7.9p1-10+deb10u1           amd64        secure shell (SSH) server, for secure access from remote machines
ii  openssh-sftp-server            1:7.9p1-10+deb10u1           amd64        secure shell (SSH) sftp server module, for SFTP access from remote machines

Motif du refus de connexion
Code :
login as: root
root@192.168.0.245's password:
Access denied
root@192.168.0.245's password:

Pour info, l'installation de debian est terminée depuis 2 heures, mais les disques sont toujours en activité. Ca a un rapport avec la construction du raid ?

VHS-4 home server Extrême I
Amd Athlon ™ II X2 235e
Processeur 2700 MHz
2048 Mo mémoire
4 X 4To Raid5 WD40EFRX-68NTONO
Clé usb à l'arrière du vhs-4 pour HDD > 2to
Version micro logiciel : 6.1.4

En informatique, j'ai tout à apprendre.
Je suis septuagénaire.
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
24-11-2019, 17:08:19
Message : #20
RE: Mon VHS-4 a rendu l'âme....
Hello,

- Pour l'accès PuTTY, c'est normal: par défaut et pour des raisons de sécurité, le compte 'root' n'est pas autorisé à se connecter à distance (c'est dans la config /etc/ssh/sshd_config)

- Et avec un utilisateur, c'est donc possible comme tu l'as vu: openssh est bien installé et il tourne/écoute sur le bon port donc

- Pour voir s'il travaille sur la construction du RAID (ce qui ne serait pas étonnant, 4x4To quand même):
Code :
$ cat /proc/mdstat
te donnera des indications sur les travaux en cours, et l'heure de fin s'il y a lieu

- En revanche le "beau résultat", c'est pas loin mais... pas encore çà... (enfin pour moi ! Sleepy)
Par comparaison, la même commande sur le VHS - OS VHT - donne:
Code :
admin@sesame:~$ sudo lsblk -o name,model,type,size,fstype,state,mountpoint
NAME    MODEL            TYPE    SIZE FSTYPE            STATE   MOUNTPOINT
sda     WDC WD40EFRX-68W disk    3.7T                   running
├─sda1                   part  485.4M swap                      [SWAP]
├─sda2                   part    4.7G linux_raid_member        
│ └─md0                  raid1   4.7G ext4                      /
└─sda3                   part    3.6T linux_raid_member        
  └─md3                  raid5  10.9T ext4                      /mnt/data
sdb     WDC WD40EFRX-68W disk    3.7T                   running
├─sdb1                   part  485.4M swap                      [SWAP]
├─sdb2                   part    4.7G linux_raid_member        
│ └─md0                  raid1   4.7G ext4                      /
└─sdb3                   part    3.6T linux_raid_member        
  └─md3                  raid5  10.9T ext4                      /mnt/data
sdc     WDC WD40EFRX-68N disk    3.7T                   running
├─sdc1                   part  486.4M swap                      [SWAP]
├─sdc2                   part    4.7G linux_raid_member        
│ └─md0                  raid1   4.7G ext4                      /
└─sdc3                   part    3.6T linux_raid_member        
  └─md3                  raid5  10.9T ext4                      /mnt/data
sdd     WDC WD40EFRX-68W disk    3.7T                   running
├─sdd1                   part  486.4M swap                      [SWAP]
├─sdd2                   part    4.7G linux_raid_member        
│ └─md0                  raid1   4.7G ext4                      /
└─sdd3                   part    3.6T linux_raid_member        
  └─md3                  raid5  10.9T ext4                      /mnt/data

=> Il n'y a pas du tout de volume lvm (mais bon, pourquoi pas ?)
=> Ton système me semble monté dans le /dev/md1, c'est à dire avec les données et pas "à part" (sur le VHS, il y a un montage spécifique du raid5 /dev/md3 dans /mnt/data)
=> Sur le /dev/md0 système chez toi, en fait j'ai l'impression qu'il n'y a que le boot
=> Ce qui veut dire que toutes les installations futures iront aussi là, mélangées avec les données (OMV aussi donc)...

Bon, "presque" alors... si je comprends bien tout !

Il faudrait que j'essaie, pour voir exactement les options proposées dans l'installateur...
Mais je ne pourrais pas le faire sur mon VHS "sesame" tant que je n'aurais pas fini sur "wasabi", pour y placer mes données.

@suivre

[Image: logo-forum.png]
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
Poster une réponse 


Aller à :




Contact | Ve-hotech | Retourner en haut | Retourner au contenu | Version bas-débit (Archivé) | Syndication RSS