Poster une réponse 
 
Note de cette discussion :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Accès SSH au VHS-4 bloqué
15-08-2019, 21:45:17
Message : #71
RE: Accès SSH au VHS-4 bloqué
(15-08-2019 21:09:59)kennely a écrit :  ...
Je me connecte en ssh du Notebook au synology
Code :
kennely@Notebook:~$ ssh admin@synology
admin@synology's password:
admin@Synology_DS918:~$
Ca fonctionne
...
Pas vraiment: il te demande un mot de passe, pas la passphrase ? (ou bien il te rend le prompt tout de suite, sans saisie ?)

Pour l'outil, j'interdis le popup d'incription aussi (ou si je l'autorise, je ne m'en sert pas): Il m'ouvre la fenêtre texte en cliquant sur l'export...
Je suis sous Debian Stretch / bureau XFCE avec Firefox "Quantum" 68.0.1 (64 bits) - Et même tor 8.5.4 (based on Mozilla Firefox 60.8.0esr) (64 bits) fonctionne..

Tu as des problèmes réseau quoiqu'il en soit: passe pas la nuit dans tes vieux cours quand même ... Tongue

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 16 Go DDR3
* 4x4To WD40EFRX - RAID 5 | OS VHT v 6.1.4
----
VHS-4 VX "wasabi" ==> Tests FreeNAS-11.2-U5 en cours...
* Intel® Core i5 2405s @ 2.5 GHz | 16 Go DDR3
* HDD système 250Go - 3x 4To ZFS RaidZ2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 22:37:24
Message : #72
RE: Accès SSH au VHS-4 bloqué
J'ai configuré 4 machines, pour l'instant je n'ai aucune connexion qui fonctionne avec passphrase.
Là, c'est un problème de configuration sshd_config.

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
16-08-2019, 04:48:44 (Ce message a été modifié le : 16-08-2019 05:13:28 par kennely.)
Message : #73
RE: Accès SSH au VHS-4 bloqué
Voici le résultat d'un test de connection ssh du Notebook au RPI
Code :
kennely@Notebook:~$ ssh -v 10.0.0.101
OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n  7 Dec 2017
debug1: Connecting to 10.0.0.101 [10.0.0.101] port 22.
debug1: Connection established.
debug1: identity file /home/kennely/.ssh/id_rsa type 0
debug1: key_load_public: No such file or directory
debug1: identity file /home/kennely/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/kennely/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/kennely/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/kennely/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/kennely/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/kennely/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/kennely/.ssh/id_ed25519-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.3
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.4p1 Raspbian-10+deb9u4
debug1: match: OpenSSH_7.4p1 Raspbian-10+deb9u4 pat OpenSSH* compat 0x04000000
debug1: Authenticating to 10.0.0.101:22 as 'kennely'
debug1: SSH2_MSG_KEXINIT sent
Connection reset by 10.0.0.101 port 22
kennely@Notebook:~$
et de nmap
Code :
kennely@Notebook:~$ nmap -v 10.0.0.101

Starting Nmap 7.60 ( https://nmap.org ) at 2019-08-16 04:11 CEST
Initiating Ping Scan at 04:11
Scanning 10.0.0.101 [2 ports]
Completed Ping Scan at 04:11, 0.00s elapsed (1 total hosts)
Initiating Connect Scan at 04:11
Scanning octopi (10.0.0.101) [1000 ports]
Discovered open port 443/tcp on 10.0.0.101
Discovered open port 22/tcp on 10.0.0.101
Discovered open port 80/tcp on 10.0.0.101
Completed Connect Scan at 04:11, 0.38s elapsed (1000 total ports)
Nmap scan report for octopi (10.0.0.101)
Host is up (0.033s latency).
Not shown: 997 closed ports
PORT    STATE SERVICE
22/tcp  open  ssh
80/tcp  open  http
443/tcp open  https

Read data files from: /usr/bin/../share/nmap
Nmap done: 1 IP address (1 host up) scanned in 0.42 seconds
kennely@Notebook:~$

Bon, cela a été laborieux mais j'ai réussi à faire une connexion ssh du Notebook vers le RPI et réciproquement.
Il devait y avoir une coquille dans l'installation de openssh-server.
J'ai fait un
Code :
sudo apt remove openssh-server
suivi de
Code :
sudo apt install openssh-server
J'ai ensuite généré les clés rsa sur le RPI et ai copiées sa clé publique sur le Notebook.
J'ai copié la clé publique du notebook sur le RPI.
J'ai fait une connection ssh dans un sens, puis dans l'autre.
Cela foctionne, avec password pour l'instant.
C'est normal car je n'ai pas terminé mes autres configurations

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
16-08-2019, 10:05:08 (Ce message a été modifié le : 16-08-2019 11:40:14 par kennely.)
Message : #74
RE: Accès SSH au VHS-4 bloqué
J'ai poursuivi ma configuration.
Pour l'instant j'ai pu activer les connexions SSH souhaitées entre les différentes machines.
Il reste un point bloquant sur le VHS.
Je veux pouvoir me connecter dessus en ssh depuis le Notebook et le RPI.

Je copie les clés publiques de Notebook et RPI
Code :
kennely@Notebook:~$ ssh-copy-id admin@192.168.1.20
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed
/usr/bin/ssh-copy-id: ERROR: ssh: connect to host 192.168.1.20 port 22: Connection refused
kennely@Notebook:~$

pi@octopi:~$ ssh-copy-id admin@192.168.1.20
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed
/usr/bin/ssh-copy-id: ERROR: ssh: connect to host 192.168.1.20 port 22: Connection refused
pi@octopi:~$
J'ai bien activé la connexion ssh sur le port 22, via le menu du VHS, avant de vouloir copier les clés.
Pensant être tombé sur un problème similaire à celui rencontré sur le RPI, j'ai désinstallé et ré-installé openssh-server sur le VHS.
Pas de chance cette fois, cela ne règle pas le problème.
Code :
admin@vhs:/$ sudo grep 'sshd' /var/log/auth.log
Aug 16 11:01:30 vhs-4 sudo: admin : TTY=tty1 ; PWD=/mnt/data/data/users/admin ; USER=root ; COMMAND=/bin/grep sshd /var/log/auth.log
admin@vhs:/$
Petites vérifications
Code :
admin@vhs:~$ sudo ps -aux | grep sshd
[sudo] Mot de passe de admin:
admin  12982  0.0  0.0  2248  tty1    S+   11:13   0:00 grep ssh
admin@vhs:~$
puis
Code :
admin@vhs:~$ sudo netstat -tlnp | grep sshd
admin@vhs:~$
je redémarre ssh
Code :
admin@vhs:/$  sudo service ssh restart
ssh stop/waiting
ssh start/running, process 24415
admin@vhs:/$
puis nouveaux contrôles
Code :
admin@vhs:~$ sudo ps -aux | grep sshd
[sudo] Mot de passe de admin:
admin  13392  0.0  0.0  29376  tty1    S+   11:17   0:00 grep ssh
admin@vhs:~$

Code :
admin@vhs:~$ sudo netstat -tlnp | grep sshd
admin@vhs:~$

Heu, je fais quoi maintenant ?

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
16-08-2019, 16:49:37
Message : #75
RE: Accès SSH au VHS-4 bloqué
Hello,

(ta quasi nuit blanche n'a pas tout réglé... décidément, quand ça veut pas ! Dodgy)

Donc sur le NAS, le serveur ssh ne tourne pas!
je propose de jongler avec les commandes de (re)démarrage du service ssh et de contrôles ps/netstat et les commandes de consultation des logs comme en #31.

Peut-être qu'il donnera des billes sur quelque chose qui lui déplaît ? La dernière fois qu'on a eu ça sur VHS, tu as repris mon fichier /etc/ssh/sshd_conf non ?

Bon...

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 16 Go DDR3
* 4x4To WD40EFRX - RAID 5 | OS VHT v 6.1.4
----
VHS-4 VX "wasabi" ==> Tests FreeNAS-11.2-U5 en cours...
* Intel® Core i5 2405s @ 2.5 GHz | 16 Go DDR3
* HDD système 250Go - 3x 4To ZFS RaidZ2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
16-08-2019, 17:36:15 (Ce message a été modifié le : 16-08-2019 20:23:53 par kennely.)
Message : #76
Wink RE: Accès SSH au VHS-4 bloqué
(16-08-2019 16:49:37)Cram28 a écrit :  La dernière fois qu'on a eu ça sur VHS, tu as repris mon fichier /etc/ssh/sshd_conf non ?

Oui, j'avais fait cela, mais la désinstallation et réinstallation de openssh-server a génère un fichier sshd_conf propre.
C'est comme cela que j'ai réglé le problème de connexion au RPI, mais ça ne suffit pas sur le vhs.
Je veux bien relancer plusieurs fois le service sshd mais je doute que le problème disparaisse tout seul.
J'ai également fait un reboot du vhs.
Comme très souvent, je dois avoir un enchevêtrement de plusieurs problèmes, mais ce que je sais, c'est que je vais finir par y arriver Wink

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
16-08-2019, 19:45:11
Message : #77
RE: Accès SSH au VHS-4 bloqué
Il à l'air carrément viré oui...Huh

Que retournent les commandes suivantes:
Code :
$ ssh  # puis < touche TAB plusieurs fois >. Si pas retour après 3/4 touches, inutile d'aller plus loin...
$ apt-cache policy openssh-server
$ dpkg-query -s openssh-server

Attention: tu es sous Ubuntu Trusty 14.04.2 sur le VHS, avec un system d'init systemV. Ceci implique:
- "sudo apt-get install ..." et pas "apt install"
- "systemctl" est associé à systemd, donc ne marche pas ici
- tu as une erreur: manque un "/" devant "etc/init.d/sshd restart" (même si ça marche pas)

Citation :Comme très souvent, je dois avoir un enchevêtrement de plusieurs problèmes, mais ce que je sais, c'est que je vais finir par y arriver Wink
J'en suis sûr, tu m'as l'air assez tétu pour çà !! Big GrinTongue

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 16 Go DDR3
* 4x4To WD40EFRX - RAID 5 | OS VHT v 6.1.4
----
VHS-4 VX "wasabi" ==> Tests FreeNAS-11.2-U5 en cours...
* Intel® Core i5 2405s @ 2.5 GHz | 16 Go DDR3
* HDD système 250Go - 3x 4To ZFS RaidZ2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
16-08-2019, 21:17:21
Message : #78
RE: Accès SSH au VHS-4 bloqué
(16-08-2019 19:45:11)Cram28 a écrit :  Il à l'air carrément viré oui...Huh
Je crois que c'est moi.
La bonne commande pour redémarrer ssh c'est
Code :
sudo service ssh restart et pas sshd
Code :
Attention: tu es sous Ubuntu Trusty 14.04.2 sur le VHS, avec un system d'init systemV. Ceci implique:
- "sudo apt-get install ..." et pas "apt install"
J'ai jamais vraiment compris pourquoi changer de syntaxe en fonction de la version.
Pourquoi Ve-hotech n'à pas fait d'upgrade de version Linux ?
J'ai refait l'installation d' openssh-server avec apt-get, et ai pu copier sa clé public sur le Synology.

Bon je vérifie tous les droits et fichiers /etc/ssh/sshd_config avant de mettre l'authentification par passphrase.

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
16-08-2019, 21:25:01
Message : #79
RE: Accès SSH au VHS-4 bloqué
Hello,

Citation :Pourquoi Ve-hotech n'à pas fait d'upgrade de version Linux ?
Cà c'est une question qu'elle est bonne !! D'ailleurs l'OS VHT est obsolète car Ubuntu Trusty 14.04 n'est plus maintenue depuis avril Angry

Citation :Bon je vérifie tous les droits et fichiers /etc/ssh/sshd_config avant de mettre l'authentification par passphrase.
Et garde-toi une copy genre
Code :
cp /etc/ssh/sshd_config /etc/ssh/sshd_config.original 

D'ailleurs, je n'ai pas eu besoin de la modifier cette config dans mes essais - certes de base. Par curiosité, quels moyens/outils utilises-tu pour miodifier ? un simple "nano" local ? Ou bien ?

@+

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 16 Go DDR3
* 4x4To WD40EFRX - RAID 5 | OS VHT v 6.1.4
----
VHS-4 VX "wasabi" ==> Tests FreeNAS-11.2-U5 en cours...
* Intel® Core i5 2405s @ 2.5 GHz | 16 Go DDR3
* HDD système 250Go - 3x 4To ZFS RaidZ2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
16-08-2019, 21:43:17
Message : #80
RE: Accès SSH au VHS-4 bloqué
(16-08-2019 21:25:01)Cram28 a écrit :  
Citation :Cà c'est une question qu'elle est bonne !! D'ailleurs l'OS VHT est obsolète car Ubuntu Trusty 14.04 n'est plus maintenue depuis avril Angry
Qu'est-ce qui nous empêche de le faire ?

Citation :Et garde-toi une copy
J'ai fait mieux.
Toute la configuration et les règles d'accès entre serveurs ont été sauvegardées sur le NAS VHS qui lancera un rsync sur le NAS Synology.
Enfin dès que ce sera fait, parce-que c'était cela l'objectif de mettre en place le ssh.

Ton fichier sshd_config n'est pas le même que celui généré lors de l'installation de openssh-server.
Oui je le modifie via nano, ou vi, car pas installé sur le Synology qui ne connaît ni
Code :
sudo apt install openssh-server
ni
Code :
sudo apt-get install openssh-server
La commande
Code :
lsb-release - a
ne donne rien non plus

@+ et un grand merci à toi et à Epy.
Je ferai un retour pour confirmer que tout fonctionne correctement.
Finalement mes problèmes de 2 openssh-server mal installé et de problème de droits sur le répertoire .ssh du compte admin du vhs.

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
Poster une réponse 


Aller à :




Contact | Ve-hotech | Retourner en haut | Retourner au contenu | Version bas-débit (Archivé) | Syndication RSS