Poster une réponse 
 
Note de cette discussion :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Accès SSH au VHS-4 bloqué
14-08-2019, 23:17:11
Message : #61
RE: Accès SSH au VHS-4 bloqué
Bonsoir,

D'abord merci beaucoup pour tes efforts de mise en forme: Là c'est 'achment plus lisible !

Et donc :
==> Le notebook est parfait en client (générer et envoyer la clé) et en serveur (sshd -D tourne et écoute sur le bon port): nickel de 1.a à 4.a
En revanche 5.a échoue, tu ne parviens pas a envoyer la clé publique vers le RPi, parce que le RPi lui n'est pas bon en serveur...

==> Le RPi est parfait en client mais ne fait pas tourner les serveur ssh: 2.b pas de retour sshd -D, 3.b pas de port d'écoute. Dans ces conditions, c'est normal que tu es une erreur dans l'envoie de la clé Notebook > RPi à l'étape d'avant 5.a.
Quelle est ta version sur RPI, Raspbian ? Gère systemd ?
Essaie
Code :
sudo systemctl restart ssh
pour le lancer et refais les vérif. serveur pour s'assurer qu'il tourne: 2.b ps et 3.b netstat. Si Ok, refait l'envoie de clé en 5.a depuis le NoteBook.
4.b et 5.b parfaits, 6.b: Sûr de ta passphrase ? (sinon n'en mets pas à la génération de ta clé, au moins pour lever ce "risque-là"... Wink)

==> Ta nouvelle tentative d'export de la clé publique du Notebook, vers le Raspberry contient une boulette: tu envoie la clé sur lui-même Smile:
Code :
kennely@Notebook:~$ ssh-copy-id kennely@Notebook
De même, tu te connectes sur toi-même Big Grin:
Code :
kennely@Notebook:~$ ssh kennely@Notebook
(Et visiblement, il peut faire des mises à jour !)

Sinon: RPI => Notebook OK, faut juste que tu trouves pourquoi ssh serveur tourne pas sur RPi, ni au démarrage un truc genre
Code :
sudo systemctl enable sshd
?? je suis pas très sûr, j'ai pas vérifié Blush

Raconte la suite !! (ça va être bon çà pour le wiki Tongue)
Merci, @+

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 16 Go DDR3
* 4x4To WD40EFRX - RAID 5 | OS VHT v 6.1.4
----
VHS-4 VX "wasabi" ==> Tests FreeNAS-11.2-U5 en cours...
* Intel® Core i5 2405s @ 2.5 GHz | 16 Go DDR3
* HDD système 250Go - 3x 4To ZFS RaidZ2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 01:06:53
Message : #62
RE: Accès SSH au VHS-4 bloqué
(14-08-2019 23:17:11)Cram28 a écrit :  Version Linux
Le RPI, est un Raspbian modifié pour gérer une imprimante 3D (Octoprint)
Version Linux 4.14.79-v7+
Il gère systemd
Code :
pi@octopy:~$
sudo ps -aux | grep sshd
pi         694  0.0  0.0   3796   228 ?        Ss   00:41   0:00 /usr/bin/ssh-agent x-session-manager
pi         739  0.0  0.0   3796   228 ?        Ss   00:41   0:00 /usr/bin/ssh-agent -s
root       925  0.0  0.4  10208  4636 ?        Ss   00:42   0:00 /usr/sbin/sshd -D
pi@octopy:~$

sudo netstat -tlnp | grep sshd
pi        1003  0.0  0.0   4672   532 tty1     S+   00:55   0:00 grep --color=auto ssh
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      925/sshd
tcp6       0      0 :::22                   :::*                    LISTEN      925/sshd

Nouvel essaie d'envoi de clé du Notebook
Code :
kennely@Notebook:~$ ssh-copy-id pi@octopi
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed

/usr/bin/ssh-copy-id: ERROR: ssh: connect to host octopi port 22: No route to host

kennely@Notebook:~$

Il est tard, la suite demain ...

Merci pour ton aide, @+

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 01:13:29
Message : #63
RE: Accès SSH au VHS-4 bloqué
Yep ! T'as raison il est tard Rolleyes:
Remplacer
Code :
kennely@Notebook:~$ ssh-copy-id pi@octopi
par
Code :
kennely@Notebook:~$ ssh-copy-id pi@octopy
(i par y dans octopy)

Nan Tongue

A bientôt pour de nouvelles aventures, bonne nuit.

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 16 Go DDR3
* 4x4To WD40EFRX - RAID 5 | OS VHT v 6.1.4
----
VHS-4 VX "wasabi" ==> Tests FreeNAS-11.2-U5 en cours...
* Intel® Core i5 2405s @ 2.5 GHz | 16 Go DDR3
* HDD système 250Go - 3x 4To ZFS RaidZ2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 01:24:42 (Ce message a été modifié le : 15-08-2019 04:09:25 par kennely.)
Message : #64
RE: Accès SSH au VHS-4 bloqué
Code :
kennely@Notebook:~$ ssh-copy-id pi@octopy
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed

/usr/bin/ssh-copy-id: ERROR: ssh: Could not resolve hostname octopy: Name or service not known

kennely@Notebook:~$
Code :
kennely@Notebook:~$ ssh-copy-id pi@octopi
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed

/usr/bin/ssh-copy-id: ERROR: ssh: connect to host octopi port 22: No route to host

kennely@Notebook:~$

Code :
kennely@Notebook:~$ sudo route -n
Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
0.0.0.0         10.0.0.1        0.0.0.0         UG    600    0        0 wlo1
10.0.0.0        0.0.0.0         255.255.255.0   U     600    0        0 wlo1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlo1
kennely@Notebook:~$

Je ping le Notebook depuis le RPI
Code :
pi@octopi:~$ ping 10.0.0.15
PING 10.0.0.15 (10.0.0.15) 56(84) bytes of data.
64 bytes from 10.0.0.15: icmp_seq=1 ttl=64 time=0.042 ms
64 bytes from 10.0.0.15: icmp_seq=2 ttl=64 time=0.040 ms
64 bytes from 10.0.0.15: icmp_seq=3 ttl=64 time=0.059 ms
64 bytes from 10.0.0.15: icmp_seq=4 ttl=64 time=0.060 ms
64 bytes from 10.0.0.15: icmp_seq=5 ttl=64 time=0.063 ms
64 bytes from 10.0.0.15: icmp_seq=6 ttl=64 time=0.061 ms

--- 10.0.0.15 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5121ms
rtt min/avg/max/mdev = 0.040/0.054/0.063/0.010 ms
pi@octopi:~$

Je ping le RPI depuis le Notebook
Code :
kennely@Notebook:~$ ping 192.168.1.100
PING 192.168.1.100 (192.168.1.100) 56(84) bytes of data.
From 192.168.1.30 icmp_seq=1 Destination Host Unreachable
From 192.168.1.30 icmp_seq=2 Destination Host Unreachable
From 192.168.1.30 icmp_seq=3 Destination Host Unreachable
From 192.168.1.30 icmp_seq=4 Destination Host Unreachable
From 192.168.1.30 icmp_seq=5 Destination Host Unreachable
From 192.168.1.30 icmp_seq=6 Destination Host Unreachable

--- 192.168.1.100 ping statistics ---
9 packets transmitted, 0 received, +6 errors, 100% packet loss, time 8106ms
pipe 3
kennely@Notebook:~$

192.168.1.30 est l'adresse du switch où est branché le RPI, VHS, SYNOLOGY

Je voulais faire un schéma tout simple, mais tous les espaces sont retirés et ça devient illisible

Bonne nuit

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 09:31:33 (Ce message a été modifié le : 15-08-2019 09:32:53 par Cram28.)
Message : #65
RE: Accès SSH au VHS-4 bloqué
Bonjour,

Oula, des problèmatiques réseau: je vais vite être largué moi, surtout avec les histoires de sous-réseaux... !
Apparemment, RPi, VHS et Syno sont sur un même réseau, le notebook est sur un autre ?

De ce ce que j'entends, un switch n'a pas d'adresse IP (il travaille au niveau MAC), il en a une s'il est "administrable" et elle ne sert que dans ce cadre.
C'est un routeur plutôt, et 192.168.1.30 est son adresse (@ de passerrelle quand tu configures) ?

Peut-être un autre fil sur ces problèmes réseau - qu'on se mélange pas les ...fils Tongue ?

Question: il s'agit bien d'une machine "physique" ton notebook, pas de VM ?

PS: j'ai trouvé un outil en ligne vite fait: http://asciiflow.com/#Draw (export, copier/coller entre balises [ code ] / [ /code ])
Code :
+----------------+
| Syno           |
| 192.168.1.xxx  +---------------------+
+----------------+                     |
                                       |
                                    +--+--------------+         +---------------+
+----------------+                  | Swith     |-----|         | NoteBook      |
| VHS            |                  | Routeur   ----------------+ 10.0.0.15     |
| 192.168.1.yyy  +------------------+ 192.168.1.30 ?|-|         +---------------+
+----------------+                  +--+--------------+
                                       |
                                       |
+----------------+                     |
| RPI            |                     |
| 192.168.1.100  +---------------------+
+----------------+

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 16 Go DDR3
* 4x4To WD40EFRX - RAID 5 | OS VHT v 6.1.4
----
VHS-4 VX "wasabi" ==> Tests FreeNAS-11.2-U5 en cours...
* Intel® Core i5 2405s @ 2.5 GHz | 16 Go DDR3
* HDD système 250Go - 3x 4To ZFS RaidZ2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 13:57:54 (Ce message a été modifié le : 15-08-2019 14:00:43 par kennely.)
Message : #66
RE: Accès SSH au VHS-4 bloqué
L'enregistrement dans asciflow ne fonctionne plus.
Il exporte ses fichiers où ?

Le Notebook est ue machine physique.
Pour l'instant je ne m'occupe pas des VM.
Mon RPI était connecté au switch du sous-sol
Pour plus de souplesse, je l'ai placé à coté de mon Notepad.
Il est passé sur le routeur Netgear 2, pour se connecté en Wifi.
Ils se retrouvent dans le même sous-réseau.

J'ai décidé de limiter les connexions Wifi qu'au routeur Netgear2, pour 2 raisons.
Sa couverture Wifi est bien meilleur que celle de la live box.
Suite à un changement d'opérateur, j'ai récupéré le ssid et password de l'ancienne box, et les ai affectés à ce retur.
De cette façon, je n'ai pas eu à reconfigurer les très nombreux appareils qui se connectaient en Wifi.

Ayant avancé dans l’installation d'autres machines, je constate que le RPI peut joindre des machines en 192.168.1.xxx

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 14:30:45 (Ce message a été modifié le : 15-08-2019 14:44:44 par Cram28.)
Message : #67
RE: Accès SSH au VHS-4 bloqué
Hello,

Pas tout compris: tu enregistres rien, tu copies/colles dans ton message forum quand il ouvre la fenêtre après action sur export:
   

Puis tu insères tes balise "code".

Tel que je comprends, le problème n'est pas le RPi, c'est le notebook en 10.0.0.15 qui ne sait pas atteindre les machines en 192.168.1.x. Si toutes tes autres connexions ssh fonctionnent, ce sera confirmé me semble-t-il ?

Code :
+---------------+             +------------------+         +---------------+
|               +------------>+                  +-------->+               |
|  RPI          |             |  VHS             |         |  Syno         |
|  192.168.1.xxx+<------------+  192.168.1.yyy   |         |  192.168.1.zzz|
|               |            ++                  +<--------+               |
+------+---+----+             +------------------+         +-----+---+-----+
       ^   |                                                     ^   |
       |   |                                                     |   |
       |   |                                                     |   |
       |   |                                                     |   |
       |   |                                                     |   |
       |   +-----------------------------------------------------+   |
       +-------------------------------------------------------------+       "isolé" ?

+-----------------+---------------------------------------------------------------------------+
+                 |
      +-----------+--------+              +--------------+
      |                    |              |              |
      |   RouteurWifi      |              | NoteBook     |
      |                    +--------------+ 10.0.0.15    |
      |                    |              |              |
      +--------------------+              +--------------+

Edit: ton futur dessin va aider: ton Notebook à une adresse en 10.0.15 ?? Pourquoi, ce n'est pas le même réseau du coup, nan ?? (j'ai prévenu: je comprends à peu près que les réseau simples Tongue

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 16 Go DDR3
* 4x4To WD40EFRX - RAID 5 | OS VHT v 6.1.4
----
VHS-4 VX "wasabi" ==> Tests FreeNAS-11.2-U5 en cours...
* Intel® Core i5 2405s @ 2.5 GHz | 16 Go DDR3
* HDD système 250Go - 3x 4To ZFS RaidZ2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 15:47:44 (Ce message a été modifié le : 15-08-2019 16:48:56 par kennely.)
Message : #68
RE: Accès SSH au VHS-4 bloqué
(15-08-2019 09:31:33)Cram28 a écrit :  Apparemment, RPi, VHS et Syno sont sur un même réseau, le notebook est sur un autre ?
oui sur même réseau Notebook 10.0.0.15 - RPI 10.0.0.101

Chez moi, il ne se passe rien quand j'appuye sur Export..
Par sécurité j'ai fais une copie d'écran.
Il faut passer par un hébergeur de fichier image, pour coller le lien sur le forum ?

Avant de refaire une copie de la clé publique du Notebook sur le RPI je vérifie l'adresse ip de celui-ci :
Code :
pi@octopi:~$hostname -I
10.0.0.101
pi@octopi:~$hostname -I
je ping le RPI depuis le Notebook
Code :
kennely@Notebook:~$ ping octopi
PING Octopi (192.168.1.100) 56(84) bytes of data.
From Netgear2 (192.168.1.30) icmp_seq=1 Destination Host Unreachable
From Netgear2 (192.168.1.30) icmp_seq=2 Destination Host Unreachable
From Netgear2 (192.168.1.30) icmp_seq=3 Destination Host Unreachable
^C
--- Octopi ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 4054ms
pipe 3
kennely@Notebook:
Ca ne fonctionne pas, je remplace le hostname par son IP
Code :
kennely@Notebook:~$ ping 10.0.0.101
PING 10.0.0.101 (10.0.0.101) 56(84) bytes of data.
64 bytes from 10.0.0.101: icmp_seq=1 ttl=64 time=1.86 ms
64 bytes from 10.0.0.101: icmp_seq=2 ttl=64 time=1.86 ms
64 bytes from 10.0.0.101: icmp_seq=3 ttl=64 time=1.85 ms
64 bytes from 10.0.0.101: icmp_seq=4 ttl=64 time=2.62 ms
^C
--- 10.0.0.101 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3006ms
rtt min/avg/max/mdev = 1.857/2.051/2.621/0.333 ms
kennely@Notebook:~$

Heu, une idée lumineuse me traverse l'esprit :
N'aurai-je pas modifié le fichier /etc/hosts ?
Code :
kennely@Notebook:~$ cat /etc/hosts
127.0.0.1    localhost
127.0.1.1    notebook
10.0.0.5    CamBureau
10.0.0.10    Canon
10.0.0.200    Roomba
10.0.0.210    Epson
192.168.1.1    Livebox
192.168.1.10    Tahoma
192.168.1.20    Vhs4
192.168.1.30    Netgear2
192.168.1.90    Netgear1
192.168.1.80    Jeedom
192.168.1.100 octopi
192.168.1.199    Linksys
192.168.1.200    Synology

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
kennely@Notebook:~/tests$
Et oui, j'avais mis l'adesse en dur lorsque le RPI était sur l'autre réseau
Après mise à jour du fichier, je ping le RPI
Code :
kennely@Notebook:~$ ping octopi
PING octopi (10.0.0.101) 56(84) bytes of data.
64 bytes from octopi (10.0.0.101): icmp_seq=1 ttl=64 time=2.68 ms
64 bytes from octopi (10.0.0.101): icmp_seq=2 ttl=64 time=3.42 ms
64 bytes from octopi (10.0.0.101): icmp_seq=3 ttl=64 time=2.59 ms
64 bytes from octopi (10.0.0.101): icmp_seq=4 ttl=64 time=2.79 ms
64 bytes from octopi (10.0.0.101): icmp_seq=5 ttl=64 time=2.98 ms
^C
--- octopi ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4007ms
rtt min/avg/max/mdev = 2.596/2.895/3.425/0.298 ms
kennely@Notebook:~$
Cool, ça fonctionne
Je tente une copie de la clé publique du Noteboo sus RPI
Code :
kennely@Notebook:~$ ssh-copy-id octopi
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed

/usr/bin/ssh-copy-id: ERROR: Connection reset by 10.0.0.101 port 22

kennely@Notebook:~$

Bon je vais faire une pause car la nuit a été courte.

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 19:26:00
Message : #69
RE: Accès SSH au VHS-4 bloqué
Hello,

Pour l'outil de dessin ascii, bizarre: quel navigateur ? Chez moi, firefox marche bien...

Pour insérer une image, je l'ajoute en pièce jointe à mon message, je positionne mon curseur là où je veux positionner mon image et je fais "insérer" (au dessus des boutons "poster", "aperçu" et "brouillon"). (il te met un n° je crois). Mais l'aperçu ne la montre pas, seulement après validation et ensuite uniquement les gens logués la voient.

Pour le réseau, j'avoue n'avoir jamais eu besoin de modifier mes fichiers hosts... Le tien à l'air d'avoir un paquet d'adresses ! Et je continue de penser que si les machines ne sont pas sur les mêmes réseaux (192.168.1.x et 10.0.0.x) il devrait y avoir des config sur le/les routeurs pour qu'ils sachent se causer ?
Mais je le redit, je suis nul Blush

Enfin pour l'échec d'envoie de la clé NoteBook => RPi, il tourne sshd sur RPi ? Je veux dire si tu l'as rebooté, peut-être l'activation du service au démarrage n'est pas effective ?

Bon allez: ce soir au lit de bonheur Big Grin (moi oui, demain "y a école" Dodgy)

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 16 Go DDR3
* 4x4To WD40EFRX - RAID 5 | OS VHT v 6.1.4
----
VHS-4 VX "wasabi" ==> Tests FreeNAS-11.2-U5 en cours...
* Intel® Core i5 2405s @ 2.5 GHz | 16 Go DDR3
* HDD système 250Go - 3x 4To ZFS RaidZ2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
15-08-2019, 21:09:59
Message : #70
RE: Accès SSH au VHS-4 bloqué
J'utilise aussi Firefox.
Le site ouvre un popup qui te propose de te connecter à ton compte google, mais ça ne fonctionne plus.
Ce popup a été bloqué, mais même en l'autorisant, il ne se passe rien en cliquant sur exporter.
Je vais essayer avec un autre navigateur.

Pour mes hosts, c'est moi qui est mis toutes ces adresses, et il en manque.
De mémoire, il y a des tables de routage.
Je vais me replonger dans des vieux cours d'administration réseau.

Le notebook ping bien des machines de l'autre réseau.
J'ai créé les clés du synology et ai copié la clé publique du Notebook sous le synology (192.168.1.200)
Code :
kennely@Notebook:~$ ssh-copy-id admin@synology
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed
/usr/bin/ssh-copy-id: INFO: 1 key(s) remain to be installed -- if you are prompted now it is to install the new keys
admin@synology's password:

Number of key(s) added: 1

Now try logging into the machine, with:   "ssh 'admin@synology'"
and check to make sure that only the key(s) you wanted were added.

kennely@Notebook:~$

Je me connecte en ssh du Notebook au synology
Code :
kennely@Notebook:~$ ssh admin@synology
admin@synology's password:
admin@Synology_DS918:~$
Ca fonctionne
Par contre si j'essaie de copier la clé publique du Notebook sur le vhs (192.168.1.20)
Code :
kennely@Notebook:~$ ssh-copy-id admin@vhs
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed

/usr/bin/ssh-copy-id: ERROR: ssh: connect to host vhs port 22: Connection refused

kennely@Notebook:~$
Ca ne marche pas non plus.

Le sshd tourne sur le RPI

VHS-4 Home Server - Modèle 4210 "amélioré"

- Asus® H110I-PLUS @ 2.133 GHz
- 32 Go Corsair® Vengeance LPX DDR4 2133MHz C13 XMP
- 4 x 8 To Seagate® ST8000VN0022 Ironwolf - RAID 5
- OS VHT v 6.1.4


-
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
Poster une réponse 


Aller à :




Contact | Ve-hotech | Retourner en haut | Retourner au contenu | Version bas-débit (Archivé) | Syndication RSS