Poster une réponse 
 
Note de cette discussion :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Méfiez vous du SMART
24-02-2018, 15:10:54
Message : #51
RE: Méfiez vous du SMART
Moins secure ? Ça m'intrigue et ça me gêne un peu du coup, même si ça reste intéressant d'utiliser des containers pour manipuler les applis et l'OS d'un seul bloc
Il faut que je me documente encore du coup

Merci pour les infos Smile
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
25-02-2018, 23:21:56
Message : #52
RE: Méfiez vous du SMART
Hello Epy,

Je crois que j'ai mal compris en fait à la réflexion: tu as un problème de mac, pas de bridge... Non ? Et il n'est pas question de "raccrocher" les containers directement à leur hôte, mais bien de conserver l'isolation réseau apportée par ce bridge ?

En tous cas, je constate en effet pas mal d'écarts entre ubuntu et debian ! La config est "incomplète" (par rapport à ubuntu en tous les cas) et semble laissée à la main de l'installateur. Je n'ai pas trop fouillé encore...

Par exemple, les containers peuvent disposer d'une config commune via /etc/lxc/default.conf sur ubuntu (celui que j'ai écrit dans le post précédent). L'équivalent debian stretch est vide (enfin, contient ''lxc.network.type = empty'').

Pour moi il faut que tu le remplisses avec les données du post d'avant: pour activer le bridge et donner des adresses MAC a minima.
Ou alors dans le fichier de config du container comme je disais, mais faut le faire pour chaque...

En tous les cas, une adresse fixe peut être donnée par dnsmasq via la config de celui-ci (/etc/lxc/dnsmasq.conf, fichier qui n'est pas défini) et les options :
- server=/lxc/10.0.4.1
- dhcp-host=<nom container>,10.0.4.<cid>
par exemple...

Bon j'espère que çà avance toutes tes (re)installations machines...
PS:
- J'ai revisité le wiki et ce sujet des lxc: http://vhs.epyisageek.net/doku.php?id=vm:lxc_app_v2 .
Peut-être des pistes tu pourras trouver, même si pas tout à fait pareil... ?)
- Pour le map html, j'ai pris une autre option, plus simple et pas plus mal... (cf. mise à jour + bac à sable)


Bref, à suivre
@+, bon courage !Smile

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 2 x 8 Go DDR3
* 4 x 4 To WD40EFRX - RAID 5 | OS VHT v 6.1.3

VHS-4 VX "wasabi"
* Intel® Core i5 2405s @ 2.5 GHz | 2 x 8 Go DDR3
* 1 x 4 To WD40EFRX - JBOD | OS version 6.1.3
* Tuner TV: Dual DVB T2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
18-03-2018, 18:44:14 (Ce message a été modifié le : 18-03-2018 18:52:14 par Epy.)
Message : #53
RE: Méfiez vous du SMART
Hello

J'avance très doucement sur ces sujets.. Pour LXC il faudrait qu'on retourne dans le sujet dédié ça serait mieux :x

Pour les VM KVM je n'arrive pas à retrouver leur configuration pour les démarrer, ça n'est pas géré par les outils classiques (super..) donc pas de config récupérable facilement Sad
Au pire j'ouvre les images comme des fichiers et je récupère ce dont j'ai besoin le plus, pour éviter des heures de config (la base SQL ça va être plus chaud sans démarrer MariaDB)

VHS4 Xtreme II - AMD Athlon II X2 240e
OS: v6.1.3 / RAM: 6 Go / Stockage: 4x 3 To

Wiki de la COMMUNAUTÉ
Qu'est-ce que GNU/Linux
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
22-03-2018, 07:55:43
Message : #54
RE: Méfiez vous du SMART
Quelques news:
Dimanche soir (histoire de plus avoir le temps de faire les choses bien) j'ai pu démarrer le VHS, pas de plantage, démarrer les VM une par une, pas de plantage. Et il fonctionne depuis !
J'ai donc pu récupérer toutes les données dont j'avais pas de backup réçent pour les remonter dans des LXC ! Je ne l'ai pas encore fait mais c'est prévu

Je viens de penser à une source de panne.. très con: la RAM ! J'en ai rajouté en cours de route lors de l'upgrade mais les barettes ça vieillit ! Et ça explique les plantages aléatoires, les plantages plus rapides ou plus fréquents avec les VM démarrées ..
Le test est facile à faire en plus

Si c'est ça, yay ! pas de grosse dépense à faire pour le maintenir en vie pour mes backups distants.

VHS4 Xtreme II - AMD Athlon II X2 240e
OS: v6.1.3 / RAM: 6 Go / Stockage: 4x 3 To

Wiki de la COMMUNAUTÉ
Qu'est-ce que GNU/Linux
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
13-05-2018, 17:36:06
Message : #55
RE: Méfiez vous du SMART
J'ai encore eu une panne: système figé, plus de réseau, après plusieurs semaines sans aucun problème (en ayant mis le RAID en dégradé avec un HDD en moins).
J'ai donc lancé la réinstall de l'OS VHT tout à l'heure (après quelques galères à trouver un dock compatible pour formater les disques actuels pour qu'il ne reprenne pas l'ancien OS)
Suite à ça, je teste le tuto LXC Smile Puis je teste le passage sur LXD, et enfin je réinstalle avec une debian pour la mise en service en backup distant

Je voulais m'amuser à mettre à jour la ubuntu 14 de VHT en 16 pour voir ce qui pète, je verrai si je le fais après Tongue

VHS4 Xtreme II - AMD Athlon II X2 240e
OS: v6.1.3 / RAM: 6 Go / Stockage: 4x 3 To

Wiki de la COMMUNAUTÉ
Qu'est-ce que GNU/Linux
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
13-05-2018, 18:52:42
Message : #56
RE: Méfiez vous du SMART
Hum, en fait LXD c'est mort sur le VHS: la ubuntu 14.04 est trop vieille, c'est pas recommandé par le dév principal.

Pas grave, je vais jouer avec LXC déjà

VHS4 Xtreme II - AMD Athlon II X2 240e
OS: v6.1.3 / RAM: 6 Go / Stockage: 4x 3 To

Wiki de la COMMUNAUTÉ
Qu'est-ce que GNU/Linux
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
14-05-2018, 13:24:30
Message : #57
RE: Méfiez vous du SMART
Hello,

snap à l'air d'exister pour Trusty...
J'ai cru comprendre que le principe des paquets snap est qu'ils embarquent les librairies dont ils ont besoin (sont donc un peu plus lourds que de "simple" .deb).

Code :
sudo apt-get install snapd
sudo snap lxd

Histoire de vraiment tout casser ... Tongue

Bon, si c'est trop vieux - ce qui est de plus en plus vrai à mesure que le temps passe ...Big Grin
Merci, @+

VHS-4 VX "sesame"
* Intel® Core i7 4770s Haswell @ 3.9 GHz | 2 x 8 Go DDR3
* 4 x 4 To WD40EFRX - RAID 5 | OS VHT v 6.1.3

VHS-4 VX "wasabi"
* Intel® Core i5 2405s @ 2.5 GHz | 2 x 8 Go DDR3
* 1 x 4 To WD40EFRX - JBOD | OS version 6.1.3
* Tuner TV: Dual DVB T2
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
14-05-2018, 14:35:02
Message : #58
RE: Méfiez vous du SMART
Oui pour snap c'est ce que j'utilise pour l'installer sur debian, mais je pense que c'est à cause de la version du noyau qu'il disait ça, pareil pour Debian 8, le noyau ne supporte pas/pas bien certaines fonctionnalités

J'ai réussi (après correction de la config sans tout réinstaller \o/) à faire créer un logical volume pour chaque LXC et à créer 3 containers et à en démarrer 1. Après je sais pas où ça a merdé avec LVM mais je ne pouvais plus en créer ni supprimer. ..
Je suis dégouté, mais je vais retenter. Pas encore tenté sur le VHS4 fraichement installé non plus, mais j'ai bien avancé sur la lecture du tuto (et corrigé 2 typos)

VHS4 Xtreme II - AMD Athlon II X2 240e
OS: v6.1.3 / RAM: 6 Go / Stockage: 4x 3 To

Wiki de la COMMUNAUTÉ
Qu'est-ce que GNU/Linux
Trouver tous les messages de cet utilisateur
Citer ce message dans une réponse
Poster une réponse 


Aller à :




Contact | Ve-hotech | Retourner en haut | Retourner au contenu | Version bas-débit (Archivé) | Syndication RSS